City LifeINCOME
insurance


Talk to a local Insurance Advisor about income protection in Montreal now!

Income protection in Montreal, QC

Critical Assist® Income protection in Montreal is essential for providing peace of mind during a time when you shouldn't have to worry about finances. While budget is always a consideration, at The Co-operators, we believe you deserve more than just low cost coverage. One of the most important types of insurance you'll ever have, income protection in Montreal provides coverage, one-on-one customer care and reasonable income protection rates. Count on The Co-operators for top quality insurance coverage and outstanding customer care. Don't delay: contact us today to find out more.

Get a great deal from the name Canadians trust

Critical Assist® Income protection in Montreal can help ease financial burdens and help you focus on your recovery when dealing with critical illness or disability. With this critical illness insurance coverage, lump sum benefit amounts can range from $25, 000 to $2, 000, 000 depending upon your needs. For help selecting the right option for you, talk to a Co-operators Insurance Advisor today.

With our plan, you can use the funds you receive to continue making mortgage payments, or pay for other medical expenses not covered by OHIP or workplace insurance plans.

The Co-operators has Insurance Advisors available to answer any questions you may have about investments or insurance in Montreal. Contact us today.

Talk to us about:

Bookmark and Share

Investing in Families, by Ensuring a Greener Future

As a responsible corporate citizen, we believe in balancing our economic, environmental and social priorities. In fact, The Co-operators was recently recognized in Hewitt Associate's Green 30 guide, which identified Canada's 30 most environmentally-conscious employers. Talk to The Co-operators today about income protection in Montreal AND about what we're doing to help the environment.

Sign up for an eNewsletter today

First Name:
Last Name:
Email

All fields are required